× Pictures from user build contant using models from our contant packages

Some of my models

  • Funnis
  • Topic Author
  • Offline
  • Senior Member
  • Senior Member
  • Hello! I like to do stuff.
More
3 years 2 weeks ago #79460 by Funnis
Replied by Funnis on topic Some of my models
Actually I have updated the pack, so I have not stopped updating it, the updates are in the downloadable version. I am creating some weapons to my game, (Character based weapons and things my server needs) these weapons are not type of weapons I am not probably going to create update posts, so I might add tens of weapons without doing a single update here. There is only 2 weapons (Rusty and Sheriff's Revolver) in the game that's not showcased here. I can tell some story about those weapons, Rusty is the players first weapon (Kinda like a wooden sword) but Rusty has few attachments (Btw I am having problems with attachments), and these attachments make the gun better.

I am probably going to buy the Toolbox 2.0, so I can continue creating vehicles, ofc I could create bases, but then I had too many WIP models and it would stress me out. I am not rich. Right now I have only 9.85€ on my bank account :lol: And I still have to go buy food... I guess I am quite bad at economy :lol:

Am I here, or am I not, are you sure, or are you not. - Funnis
The topic has been locked.
More
3 years 2 weeks ago #79468 by Akach13
Replied by Akach13 on topic Some of my models
What is your problem with attachments? If you're setting their points after scaling the model then save your scale somewhere (notepad, hand, whatever) and reset it, after that, you can set the attachment points again for the unscaled model and then scale the model back. I hope you understand everything I wrote here.
The following user(s) said Thank You: Funnis
The topic has been locked.
  • Funnis
  • Topic Author
  • Offline
  • Senior Member
  • Senior Member
  • Hello! I like to do stuff.
More
3 years 2 weeks ago #79469 by Funnis
Replied by Funnis on topic Some of my models
My problem has been that the attachments don't show up in the model, they make default parts disappear but the attachments don't replace them. I am not sure if there is a problem in the models, but I am debugging my pack. I have never created attachments, so I have no slightest idea how to create one, so I am kinda improvising during the time I create those :lol:

Am I here, or am I not, are you sure, or are you not. - Funnis
The topic has been locked.
More
3 years 2 weeks ago #79470 by Akach13
Replied by Akach13 on topic Some of my models
You have a problem with your own attachments, huh? Did you set them as "Attachment" in "Model part" section? For example, if you made a silencer you need to set the whole model as "Attachment - Barrel" and then you need to export it as "Attachment - Barrel". Beware of mistake in the code - there is "flansmods" instead of "flansmod" in "Vector3f;" line, so change it.
Wrong line of code: import com.flansmods.common.vector.Vector3f;
Right line of code: import com.flansmod.common.vector.Vector3f;
The following user(s) said Thank You: Funnis
The topic has been locked.
  • Funnis
  • Topic Author
  • Offline
  • Senior Member
  • Senior Member
  • Hello! I like to do stuff.
More
3 years 2 weeks ago #79472 by Funnis
Replied by Funnis on topic Some of my models
I have to check this once I'm on my laptop! I am LAZY and I haven't installed toolbox 2.0 on my desktop :lol:

Am I here, or am I not, are you sure, or are you not. - Funnis
The topic has been locked.
  • Funnis
  • Topic Author
  • Offline
  • Senior Member
  • Senior Member
  • Hello! I like to do stuff.
More
3 years 2 weeks ago #79476 by Funnis
Replied by Funnis on topic Some of my models
I have created a working attachment! I don't have a clue where I can set the model class into a attachment base, so my attachment has no model if it's automatically generated model... I had to create the model myself :lol: by coding, ofc I took some samples from the automatically generated one, like the positions and stuff (The hard stuff). But it works now. I'd love to hear where I can get the base for attachments. Wait... I hate myself... I realized it while writing this :D:D I actually just programmed a barrel model for my weapon, when I could have just chosen it from the scrollmenu. I should go kill myself. :oops: Well, I guess I did it the Real way !!! It sucks.

Am I here, or am I not, are you sure, or are you not. - Funnis
The following user(s) said Thank You: Akach13
The topic has been locked.
 
Latest Forum Posts
 
Latest Blog Posts
 
User Online
 
User Menu