× Package only with new Guns including new Models for the Guns but no Planes or Vehicles

Upcoming "Underground Enclaves" Content pack

More
5 years 5 months ago #74432 by TheOrion

MikeTheZappaCZ wrote: Thx for reply DerpiWolf but it still dont work :C... I already had this line in my java files. Tried to replace tït with that you post there but still no animations... :C

There is another problem about the guns that i dont know how to solve... Every gun is in scale 0.15 0.20 or 0.25 but they are odd in game... They look good and stuff but they are positioned way too low in 1st person view, so when you aim them sights are 5cm under crosshair, so you cant possibly hit anything...

Did you assign anything to the "Ammo" section of your model?

As you can see, the selected parts have been reasigned in their category window.


MVP Ostwind
Attachments:
The topic has been locked.
More
5 years 5 months ago #74480 by MikeTheZappaCZ
yes i did that...



Dunno wats wrong... :C
Attachments:
The topic has been locked.
More
5 years 5 months ago #74481 by DerpiWolf
me neither. From here, I don't know what you're doing wrong.

All you need is that line to assign a reload animation. If it can't assign that at all, yet other parts of the animation code can work, then you have a flansmod code problem.

...which of course means, either your export java code is incorrect, or your flansmod is broken.
Do you run the game in eclipse or through the toolbox?
The topic has been locked.
More
5 years 5 months ago #74521 by MikeTheZappaCZ
Installing toolbox was quite hectic... I downloaded and installed java sdk then set home variable intalled toolbox.. all fine till i had to set up gradle... automatic installation hasnt worked so i downloaded files and did it with option install from a file... it set up eventually but it lagged when it was doing something with flans mod so i copy pasted insides of that folder into gradle build... Then i installed eclipse by pressing that automatic install button...
Next problem was with paths... I didnt know which one should i use so i looked at manus paths when he was saving java file and texture file... I found folder where models should be in no time but when i tried to find folder for texture files config items etc. i found nothing... in manus tutorial it was somewhere in eclipse/flan folder but i dont have such folder here... I noticed there is a folder forge/run/flan which has almost same contents like manus ones so i set it here...
Last problem is that when i run gradle and it says build succesfull i couldnt find my pack in build/libs but there is jar file called Flan's Mod-1.8-5.2 which contains compiled models of mine so i just took it off this jar file and put in MC... It is working but models in fps are positioned too low and reload anims are missing...
Thats all the story :3
The topic has been locked.
More
5 years 5 months ago #74533 by MikeTheZappaCZ
Freedom update:

Standart issued pistol M-62 Patriot



Bolt-action rifle M-57 Sentinel




Submachinegun M-59 Liberator

Attachments:
The topic has been locked.
More
5 years 5 months ago #74536 by MikeTheZappaCZ
RWEx-3 Training walker mech "Topaz" In colours of

Neuer Anfang



Vostok



Freedom

Attachments:
The topic has been locked.
 
Latest Forum Posts
 
Latest Blog Posts
 
User Online
 
User Menu